Updating plugins with .zip uploads

As detailed in this Trac ticket, when you try to upload a new version of a plugin, you get an error. Meaning, if I have a plugin on my WordPress site that needs to be updated to the latest version, or even to a development version, I can’t just upload a new .zip file to do this. Instead I have to either update from the plugins page or upload a new folder via SFTP.

Following are the steps to replicate the existing issue where you get blocked when trying to upload a new version of a plugin: