Update Trac to 1.0.16

There are a bunch of useful bits in more recent Trac 1.0 releases that we could use.

Also, the TracXMLRPC plugin had some compatibility issues with Trac 1.0, they were fixed in version 1.1.3, but there were also a handful of bug fixes in later versions, so upgrading that to 1.1.6 would be nice.