WordPress 4.2.4 Release Candidate 1

tl;dr WordPress 4.2.4 RC1 is available (download) for testing and fixes an issue with inline scripts.

A change in WordPress 4.2.3 had the unintentional side effect of breaking some inline scripts when the CDATA block is used (see #33106). For example, consider the intended content here:

<script>// <![CDATA[
_my_function('data');
// ]]>
</script>

In 4.2.2, this content is left as is and _my_function() fires as expected. In 4.2.3, the content is manipulated as such:

<script>// <![CDATA[ _my_function('data'); // ]]></script>

This results in the script being commented out by the // and it will not fire. A workaround for this is to use /* for commenting.

<script> /* <![CDATA[ */ _my_function('data'); /* ]]> */ </script>

However, this workaround should not be necessary. As a result, we intend on releasing WordPress 4.2.4 to fix this issue.

Additionally, WordPress 4.2.3 caused issues when using shortcodes within angle brackets (see #33116). For example, this shortcode usage worked in 4.2.2 but did not work in 4.2.3:

<[shortcode]>

While we do not recommend this use of shortcodes and strongly encourage plugin developers to move away from this use of shortcodes, the breakage was unintentional and we have restored the behavior in WordPress 4.2.4 RC1.

Please download and test WordPress 4.2.4 RC1 and report any issues to core trac or to this post.

#4-2, #4-2-4