WP-CLI v2.0.1 Release Notes

A bugfix release was in order, as the new i18n make-pot command was not properly packaged in v2.0.0!

For this release, 9 contributors have produced 19 pull requests and squashed 12 bugs.

Breaking change

The only thing of note as a (potential) breaking change is “Throw error in theme fetcher on non-lowercase slugs” [#126]. It should turn scenarios that produce a success message and actually failed into error messages instead. However, given the many possible combinations of encodings and filesystem quirks, what should have failed might previously actually have worked out of sheer coincidence instead. This will now throw an error message nevertheless.

Complete change log

wp-cli/wp-cli-bundle

  • Add i18n-command dependencies to make-phar [#14]

wp-cli/wp-cli

  • Update dependencies and avoid redefining WP_CLI_ROOT [#4918]
  • Make pick_fields() work with numeric headers [#4916]
  • Automatically rerun failed scenarios [#4906]
  • Skip releases that lack a downloadable asset [#4923]

wp-cli/config-command

  • Permit use of wp config edit when WP isn’t functional [#71]

wp-cli/entity-command

  • Update readme [#204]
  • Automatically rerun failed scenarios [#200]

wp-cli/extension-command

  • Throw error in theme fetcher on non-lowercase slugs [#126]
  • Raise timeout for HTTP requests to 1 minute [#125]
  • Automatically rerun failed scenarios [#119]

wp-cli/i18n-command

  • Require framework as hard dependency [#78]
  • Add Composer config settings [#74]

wp-cli/language-command

  • Make sure upgrader strings are always in English [#54]
  • Slug fixes [#53]
  • Automatically rerun failed scenarios [#50]
  • Change access to activate_language()to private [#47]

wp-cli/scaffold-command

  • PHPCS template: fix XML error in ruleset [#171]
  • Automatically rerun failed scenarios [#170]

Contributor List

@arunsathiya, @danielbachhuber, @javorszky, @jrfnl, @Mr-Alexander, @ocean90, @schlessera, @swissspidy, @wojsmol

#v2-0-1