This morning I ran another user through the same media scenarios that I had tested previously.

You can download the video here (warning, it’s 27 min long – 69MB).

My observations:

Step 1: Login

No problems.

Step 2: Publish already uploaded image

2:44-5:19 – I copied over the instructions from the last test, as such didn’t specifically tell him to go to the media library – so he had issues finding the “two cows” picture I had mentioned.

Step 3: Preview post

No problems.

Step 4: Publish 2 images to a single post

8:14-10:00 – Found his way to the “media library” instead of using “QuickPress” as instructed.
10:20 – Got back on track.
10:48 – He was unsure as to whether he should click “Create a new gallery” or “Batch insert”
11:15 – After he clicked the “Batch insert” button, he was unsure what he should do next – “Now am I waiting for this to be done?”
11:42-14:40 – Tried multiple times previewing his post in QuickPress before publishing it (and lost his work each time).
14:50 – Finally figured it out.

Step 5: Download additional images

No problems

Step 6: Upload new images & publish gallery

19:50-22:10 – When asked to upload multiple images, he uploaded one at a time, and after adding one, couldn’t figure out how to add the other image.
22:14 – Let’s try it again. He again has issues figuring out what to do after adding one image. “I don’t think I could have added them both at the same time, I don’t know”
22:48 – He repeatedly tries to click “Upload Files” after already uploading one image, but it does nothing.
23:10 – Again forgets to hit “Publish” before trying to preview his image :-(
23:37 – Starts over again. And get’s it after attempting to upload both images at the same time.
24:55 – He added a description to both images from the “upload” screen, and immediately clicked the “Create a new gallery” button – his second description did not save.
25:25 – Again forgot to click publish, before trying to preview, but quickly recognized his error, and was able to salvage it by clicking the back button.

Summary

  • Some uncertainty as to whether he should click “Create a new gallery” or “Batch insert”
  • Some uncertainty after he clicked “Batch insert”, as to what he should do next.
  • Tried half a dozen times to preview his post (by clicking the “View my site” link in the welcome area) before clicking “Publish” (in QuickPress). Can we add a “Are you sure you want to leave this page” warning?
  • He didn’t realize that he could upload multiple images. Is there something we could add (description, or illustration) indicating that this can be done?
  • When he wanted to upload multiple images, he did so one at a time, and got stuck after adding the first one (not being able to go back and add another).
  • Adding a description, and then immediately clicking “Create a new gallery” results in the description not being saved.
  • There were enough things that popped up in this one, that I’m going to run another user through this evening.