I’ve updated wp-themes.com to use WordPress 3.4, that way I could fix #WP20514. This could potentially reveal themes that are broken in 3.4, so keep an eye out. I will be watching the error logs.