A change to api.wordpress.org temporarily broke the API that powers the plugin install screens in your WordPress dashboard. If you saw “An unknown error occurred during the API request” when going to Plugins → Add New, it was us, not you.

Sorry for the inconvenience.

I’ve created a bug report to improve the error message shown to users, in the very rare event that something goes wrong on wordpress.org. That should be included in WordPress 3.4 (and is hopefully an error message you will never have to see).