Marked 3.0.1 as RC. Grab the Beta Tester plugin and set it to “Point release nightlies” to upgrade from 3.0 to 3.0.1-RC1.

3.0.1 has been added to the compatibility dropdown in the plugins dir. 3.0.1 is marked as equivalent to 3.0 so the automatic updater should report 3.0 compatible plugins as being 3.0.1 compatible as well.